summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJack Chen2020-04-09 02:15:34 +0800
committerJack Chen2020-04-09 02:15:34 +0800
commitac542c60cf542420fbe9ad88f1f2be67ec21912e (patch)
tree041760a8240e6736af264a6a3b0d95855d1ce2e9 /PKGBUILD
parent88748ea3d00ec1b5a23b3823f8644adbd1379b87 (diff)
downloadaur-ac542c60cf542420fbe9ad88f1f2be67ec21912e.tar.gz
use the api provided by api.opengapps.org to obtain the release date of gapps
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD4
1 files changed, 2 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 0c9836cb613b..bb6d65b3f1c0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=anbox-image-gapps
pkgver=2018.07.19
-pkgrel=14
+pkgrel=15
pkgdesc="Android image for running in Anbox, with OpenGApps and Houdini"
arch=('x86_64')
url="https://anbox.io"
@@ -13,7 +13,7 @@ makedepends=('curl' 'lzip' 'squashfs-tools' 'unzip')
provides=('anbox-image')
conflicts=('anbox-image')
-_gapps_rel="$(curl -s -L https://api.github.com/repos/opengapps/x86_64/releases/latest | head -n 10 | grep tag_name | sed -r 's/.*\"([0-9]+)\".*/\1/')"
+_gapps_rel="$(curl -s -L https://api.opengapps.org/list | sed -r 's/.*-x86_64-7.1-pico-([0-9]+).zip".*/\1/')"
_gapps_src="https://downloads.sourceforge.net/project/opengapps/x86_64/$_gapps_rel/open_gapps-x86_64-7.1-pico-$_gapps_rel.zip"
_gapps_md5="$(curl -s -L $_gapps_src.md5 | sed -r 's/^([0-9a-z]+).*/\1/')"
_gapps_list=(