summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMubashshir2022-01-07 21:29:31 +0600
committerMubashshir2022-01-07 21:29:31 +0600
commite6c14f0b240c0985b737969272b1f5362c95f5f7 (patch)
tree9d19673ea237a1343faff050639b7729e987187b /PKGBUILD
parentc96da33e6ce3760ef068c7ea9cbb5793dd486ead (diff)
downloadaur-e6c14f0b240c0985b737969272b1f5362c95f5f7.tar.gz
Fix anbox-image-nocsd bromite webview
Signed-off-by: Mubashshir <ahmubashshir@gmail.com>
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index ad1da13694f4..0f468d76c4f4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=anbox-image-nocsd
pkgver=r8.bc49df8d
-pkgrel=2
+pkgrel=3
pkgdesc="Android image for running in Anbox, with no-csd patch and Houdini"
arch=('x86_64')
url="https://anbox.io"
license=('custom')
-makedepends=('curl' 'lzip' 'squashfs-tools' 'unzip')
+makedepends=('curl' 'lzip' 'squashfs-tools' 'unzip' 'awk' 'findutils' 'grep')
provides=('anbox-image')
conflicts=('anbox-image')
@@ -125,6 +125,10 @@ build () {
cp media_codec*.xml ./squashfs-root/system/etc/
rm -rv ./squashfs-root/system/app/webview/*
cp BromiteSystemWebview.apk ./squashfs-root/system/app/webview/webview.apk
+ unzip -l BromiteSystemWebview.apk \
+ | grep 'so$' \
+ | awk '{print $4}' \
+ | xargs unzip -d ./squashfs-root/system/app/webview BromiteSystemWebview.apk
}
package() {