summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2020-01-18 18:10:11 -0300
committerGonzalo Exequiel Pedone2020-01-18 18:10:11 -0300
commitc7ff42b58919673dc474b853bdf6afcf95079173 (patch)
tree6ffeafd601477d5a3a02e9eeef8ddb22045133e6 /PKGBUILD
parent5d03626f121dbba7cf3bbc597b3255624ab6ad15 (diff)
downloadaur-c7ff42b58919673dc474b853bdf6afcf95079173.tar.gz
Added libssh support.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 96ac337682d1..3284dffa5a55 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,13 +4,14 @@ _android_arch=aarch64
pkgname=android-${_android_arch}-ffmpeg
pkgver=4.2.2
-pkgrel=1
+pkgrel=2
pkgdesc="Complete solution to record, convert and stream audio and video (android)"
arch=('any')
url="http://ffmpeg.org/"
license=('GPL3')
depends=("android-${_android_arch}-bzip2"
"android-${_android_arch}-lame"
+ "android-${_android_arch}-libssh"
"android-${_android_arch}-libtheora"
"android-${_android_arch}-libvorbis"
"android-${_android_arch}-libvpx"
@@ -48,7 +49,7 @@ build() {
case "$_android_arch" in
aarch64)
target_arch=aarch64
- export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis"
+ export LDFLAGS="-L${ANDROID_PREFIX_LIB} -lm -logg -lvorbis -lssh -lcrypto_1_1 -lssl_1_1"
;;
armv7a-eabi)
target_arch=arm
@@ -95,6 +96,7 @@ build() {
--enable-libmp3lame
--enable-libopus
--enable-libspeex
+ --enable-libssh
--enable-libtheora
--enable-libvorbis
--enable-libvpx