summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-03-17 17:51:37 -0300
committerGonzalo Exequiel Pedone2024-03-17 17:51:37 -0300
commit06818a9ef6de35578a70a762577d14757367eedc (patch)
tree61358f7230c6fecf220b70a7fd041a0830bb1f8a /PKGBUILD
parent652803ac99d10c23b44db0aa9eaf889b6c86d4de (diff)
downloadaur-06818a9ef6de35578a70a762577d14757367eedc.tar.gz
Disable pthread_atfork usage.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 5ff9d92bedea..b3c1b47fdc28 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@ _android_arch=aarch64
pkgname=android-${_android_arch}-libunistring
pkgver=1.1
-pkgrel=1
-pkgdesc="Library for manipulating Unicode strings and C strings (android)"
+pkgrel=2
arch=('any')
+pkgdesc="Library for manipulating Unicode strings and C strings (Android, ${_android_arch})"
url="https://www.gnu.org/software/libunistring/"
license=('GPL')
depends=('android-ndk'
"android-${_android_arch}-libiconv")
-options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-configure')
+options=(!strip !buildflags staticlibs !emptydirs)
source=("https://ftp.gnu.org/gnu/libunistring/libunistring-${pkgver}.tar.xz"{,.sig})
validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871' # Daiki Ueno <ueno@unixuser.org>
'9001B85AF9E1B83DF1BDA942F5BE8B267C6A406D') # Bruno Haible (Open Source Development) <bruno@clisp.org>
@@ -25,6 +25,8 @@ build() {
cd "${srcdir}"/libunistring-${pkgver}
source android-env ${_android_arch}
+ export ac_cv_func_pthread_atfork=no
+
android-${_android_arch}-configure
make $MAKEFLAGS
}