summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2020-01-19 14:29:51 -0300
committerGonzalo Exequiel Pedone2020-01-19 14:29:51 -0300
commit4f76a7f20fc52db9494df54446d67e20cb00474c (patch)
tree8376a68d6478495a0ef7d95cd530ff534544dd40 /PKGBUILD
parent786c06c34e009fea3e2667a5cddfc84670c31b6f (diff)
downloadaur-4f76a7f20fc52db9494df54446d67e20cb00474c.tar.gz
Fixed NEON related compile error, when compiling for armv7a-eabi.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 095f5127e4c6..94c746a3b0eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ _android_arch=aarch64
pkgname=android-${_android_arch}-qt5
pkgver=5.14.0
-pkgrel=1
+pkgrel=2
pkgdesc="Qt 5 for Android"
arch=('any')
url='https://www.qt.io'
@@ -65,10 +65,12 @@ _pkgfqn="qt-everywhere-src-${pkgver}"
install="${pkgname}.install"
source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:4}/${pkgver}/single/${_pkgfqn}.tar.xz"
"0001-Support-pkg-config-under-Android.patch"
- "0002-Use-pkg-config-to-find-external-libraries.patch")
+ "0002-Use-pkg-config-to-find-external-libraries.patch"
+ "0003-Fix-neon.patch")
md5sums=('e7ea948ab99a2ef0726db5eac8e4fd8e'
'6af9dcc450ae6c69d8fddccf0680d84a'
- 'f0f5dda8352a675566a08fa0f863a08b')
+ 'f0f5dda8352a675566a08fa0f863a08b'
+ '656c7eec7d37854cef1763c163c1ca98')
prepare() {
cd ${_pkgfqn}
@@ -80,6 +82,14 @@ prepare() {
patch -Np1 -i "../0001-Support-pkg-config-under-Android.patch"
patch -Np1 -i "../0002-Use-pkg-config-to-find-external-libraries.patch"
+ case "$_android_arch" in
+ armv7a-eabi)
+ patch -Np1 -i "../0003-Fix-neon.patch"
+ ;;
+ *)
+ ;;
+ esac
+
sed -i "s/android-21/android-$ANDROID_MINIMUM_PLATFORM/g" qtbase/configure.pri
}