summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-10-11 21:30:20 +0200
committerMartchus2022-10-11 21:30:20 +0200
commit184801c1702bad46435548bd247d3eef3b22c105 (patch)
tree0985ea8f0a1b790a5c0a34061b6fdfa9a19e8fba /PKGBUILD
parenta53889a2649a6cb7c509bcc68e256de3ee7c525e (diff)
downloadaur-184801c1702bad46435548bd247d3eef3b22c105.tar.gz
Update to 6.4.0
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b8a86059673e..3c92e3b96491 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_android_arch=aarch64
pkgname=android-$_android_arch-qt6-multimedia
-_qtver=6.3.1
+_qtver=6.4.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(any)
@@ -18,8 +18,20 @@ makedepends=('android-cmake' 'android-aarch64-qt6-declarative' 'android-aarch64-
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtmultimedia-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('7e03242aadd634ff2d9fcf08948290f03da3d9a5012369d908da89f82b1d7336')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Fix-compile-flags-of-resonance-audio-for-mingw-w64.patch')
+sha256sums=('e82e8e847cae2a951a11db05b6d10a22b21e3a1d72e06a7781cce4bd197e796f'
+ '2bd14f2aa5c1d23da1f5516b882463fa782f5166c37fecf4c8c15ef43257c338')
+
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
build() {
source android-env ${_android_arch}