summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2023-10-16 23:54:03 +0200
committerMartchus2023-10-16 23:54:03 +0200
commit3b6288e0bed3cb5876bb5bc5dca0ec5c87269c67 (patch)
treee55c14ff5cea534aacc3fc83752951f1b18ccf49 /PKGBUILD
parentda7e4b2d12102863655790646108852e3ec4c851 (diff)
downloadaur-3b6288e0bed3cb5876bb5bc5dca0ec5c87269c67.tar.gz
Fix crashes with malformed SVGs
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD18
1 files changed, 15 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1019678c50ac..64d2ab3eb7d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@ _android_arch=aarch64
pkgname=android-$_android_arch-qt6-svg
_qtver=6.6.0
pkgver=${_qtver/-/}
-pkgrel=1
+pkgrel=2
arch=(any)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
@@ -17,8 +17,20 @@ makedepends=('android-cmake' 'qt6-base' 'ninja' 'java-environment-openjdk>=11')
options=('!strip' '!buildflags' 'staticlibs' '!emptydirs')
groups=(android-${_android_arch}-qt6)
_pkgfqn="qtsvg-everywhere-src-${_qtver}"
-source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz")
-sha256sums=('33da25fef51102f564624a7ea3e57cb4a0a31b7b44783d1af5749ac36d3c72de')
+source=("https://download.qt.io/official_releases/qt/${pkgver%.*}/${_qtver}/submodules/${_pkgfqn}.tar.xz"
+ '0001-Fix-nullptr-dereference-with-invalid-SVG.patch')
+sha256sums=('33da25fef51102f564624a7ea3e57cb4a0a31b7b44783d1af5749ac36d3c72de'
+ '83f59c72773071df6adca9c0f6f457a460bd63a4d2b85f1e0df9cabf6b1c55e9')
+
+prepare () {
+ cd $_pkgfqn
+
+ # apply patches; further descriptions can be found in patch files itself
+ for patch in "$srcdir/"*.patch; do
+ msg2 "Applying patch $patch"
+ patch -p1 -i "$patch"
+ done
+}
build() {
source android-env ${_android_arch}