summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-07-22 17:43:18 -0300
committerGonzalo Exequiel Pedone2019-07-22 17:43:18 -0300
commit31ea2317e334af0a3f3960c95e44c5da6e81143d (patch)
treed70a3736dcf6b2a76a108ffa03b69ddb9e46704b /PKGBUILD
parentf6ce67e7283c591a184ab537ddd825184f96df04 (diff)
downloadaur-31ea2317e334af0a3f3960c95e44c5da6e81143d.tar.gz
Package updated.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 530c1303616b..e7aa5d3e2eaa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,10 @@
# Maintainer: Gonzalo Exequiel Pedone <hipersayan DOT x AT gmail DOT com>
_android_arch=armv7a-eabi
-source android-env ${_android_arch}
pkgname=android-${_android_arch}-libtheora
pkgver=1.1.1
-pkgrel=2
+pkgrel=3
pkgdesc="An open video codec developed by the Xiph.org (android)"
arch=('any')
url="http://xiph.org"
@@ -18,12 +17,14 @@ md5sums=('292ab65cedd5021d6b7ddd117e07cd8e')
prepare() {
cd "${srcdir}"/libtheora-${pkgver}
+ source android-env ${_android_arch}
autoreconf -fi -I m4
}
build() {
cd "${srcdir}"/libtheora-${pkgver}
+ source android-env ${_android_arch}
android-${_android_arch}-configure \
--disable-examples
@@ -33,6 +34,7 @@ build() {
package() {
cd "${srcdir}"/libtheora-${pkgver}
+ source android-env ${_android_arch}
make DESTDIR="$pkgdir" install
rm -r "${pkgdir}"/${ANDROID_PREFIX_SHARE}