summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2019-07-22 17:48:27 -0300
committerGonzalo Exequiel Pedone2019-07-22 17:48:27 -0300
commit434c57dbab74a474695b26fb78f49c9a38f2db95 (patch)
tree888ea84629b3a2cd301ad52a97b071832b5a1ab7 /PKGBUILD
parent423aeecf90fedeb58936e520dafe6ce9b46260de (diff)
downloadaur-434c57dbab74a474695b26fb78f49c9a38f2db95.tar.gz
Package updated.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 789b4f9f1848..9bd42086ccf7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,11 +4,10 @@
# Contributor: bubla < matej dot tyc at gmail dot com >
_android_arch=armv7a-eabi
-source android-env ${_android_arch}
pkgname=android-${_android_arch}-libtiff
pkgver=4.0.10
-pkgrel=1
+pkgrel=2
pkgdesc="Library for manipulation of TIFF images (android)"
arch=('any')
url="http://www.simplesystems.org/libtiff/"
@@ -23,6 +22,7 @@ sha256sums=('2c52d11ccaf767457db0c46795d9c7d1a8d8f76f68b0b800a3dfe45786b996e4')
build() {
cd "${srcdir}/tiff-${pkgver}"
+ source android-env ${_android_arch}
export CFLAGS="-fno-strict-aliasing"
export CXXFLAGS="-fno-strict-aliasing"
@@ -35,6 +35,7 @@ build() {
package() {
cd "${srcdir}/tiff-${pkgver}"
+ source android-env ${_android_arch}
make DESTDIR="$pkgdir" install
cp libtiff/{tiffiop,tif_dir}.h "${pkgdir}/${ANDROID_PREFIX_INCLUDE}/"