summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorxdavidwu2023-08-14 16:00:31 +0800
committerxdavidwu2023-08-14 16:00:31 +0800
commit4dd75adbeca985ff2b77e7b2e73a95bd5662e0e0 (patch)
treef4a8e5fcacd59922fa5481bc2624b900ebc8d70f /PKGBUILD
parentec378dcb198163677e35288990118e901486c61f (diff)
downloadaur-4dd75adbeca985ff2b77e7b2e73a95bd5662e0e0.tar.gz
r26_beta1, sync deps with stable package
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 571eeb7588da..e7d030f6912d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=android-ndk-beta
_pkgname=${pkgname/-beta*/}
-pkgver=r24_beta2
+pkgver=r26_beta1
pkgrel=1
pkgdesc='Android C/C++ developer kit (beta)'
arch=('x86_64')
@@ -14,18 +14,21 @@ license=('GPL' 'LGPL' 'custom')
options=('!strip' 'staticlibs')
backup=("etc/profile.d/$pkgname.sh")
install="$pkgname.install"
-depends=('glibc' 'bash')
+depends=('bash' 'glibc' 'gcc-libs' 'zlib')
optdepends=(
- 'ncurses5-compat-libs: for using gdb'
- 'python2: various helper scripts'
+ 'ncurses5-compat-libs: for curses module in bundled Python'
+ 'bzip2: for bz2 module in bundled Python'
+ 'libxcrypt-compat: for crypt module in bundled Python'
'python: various helper scripts'
+ 'perl: various helper scripts'
+ 'libc++: for some LLVM components'
)
source=("$pkgname-$pkgver.zip"::"https://dl.google.com/android/repository/${_pkgname}-${pkgver/_/-}-linux.zip"
"$pkgname.sh")
# SHA1 sums is kept to follow upstream releases https://github.com/android-ndk/ndk/issues/673
-sha1sums=('78f3006243c0bc051c7c7bfb939689032e7c41ba'
+sha1sums=('fb5e34313766764d9654b04603e69af813b18799'
'b0a3c3d4e148c1049f9c8b12f2632840630ea4db')
-sha256sums=('379c862f23f9d6a4c475ea54cb2fef67bdeacd4de20749892bd3bf2494b3f790'
+sha256sums=('0d5591dbcc6f5435b6dc4145f5a3c7db832007dede15aba9991bd81ad2324491'
'a39422d48174302e1ee27f07031f20adc78224d12c17a5451129a88b47c901c1')
package() {