summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2017-03-05 12:23:20 -0300
committerGonzalo Exequiel Pedone2017-03-05 12:23:20 -0300
commitf99a0d217c7546edf693887983bef7fad8e0852c (patch)
treeb3438265ebb7ac8f4490a6658fb6463e6a7eea4b /PKGBUILD
parent7ac0b12809de6657f77d32d882125edb396e3c67 (diff)
downloadaur-f99a0d217c7546edf693887983bef7fad8e0852c.tar.gz
Package updated.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 10 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f8bcc41ae88d..6f484011b29d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,9 +7,8 @@
android_arch=x86
_pkgname=android-qt5
pkgname=${_pkgname}-${android_arch}
-_pkgver=5.8
-pkgver=${_pkgver}.0
-pkgrel=1
+pkgver=5.8.0
+pkgrel=3
pkgdesc="Qt 5 for Android"
arch=('i686' 'x86_64')
url='https://www.qt.io'
@@ -49,22 +48,16 @@ case "$android_arch" in
esac
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
-source=("http://download.qt-project.org/official_releases/qt/${_pkgver}/${pkgver}/single/${_pkgfqn}.tar.xz"
- "JavaScriptCore.pri.patch"
- "imageformats.pro.patch")
+source=("http://download.qt-project.org/official_releases/qt/${pkgver:0:3}/${pkgver}/single/${_pkgfqn}.tar.xz"
+ "JavaScriptCore.pri.patch")
sha256sums=('0f4c54386d3dbac0606a936a7145cebb7b94b0ca2d29bc001ea49642984824b6'
- '133dad6c8d0bedaa5d561be26b2f7185e671900c50d11476ecb2e2ef6792d455'
- '943e8c03dc2218250f75cec3b663d90e6bb98d9b64b9f12b01713c284e5e4673')
+ '133dad6c8d0bedaa5d561be26b2f7185e671900c50d11476ecb2e2ef6792d455')
prepare() {
cd ${_pkgfqn}
# Platform specific patches.
case "$android_arch" in
- arm64-v8a)
- # Disable WebP image format.
- patch -Np1 -i "../imageformats.pro.patch"
- ;;
armeabi)
# Disable JIT.
patch -Np1 -i "../JavaScriptCore.pri.patch"
@@ -78,6 +71,10 @@ get_last() {
ls $1 | sort -V | tail -n 1
}
+get_last_platform() {
+ ls $1 | grep 'android-' | sort -V | tail -n 1
+}
+
build() {
cd ${_pkgfqn}
@@ -104,7 +101,7 @@ build() {
export ANDROID_API_VERSION=$(get_last ${ANDROID_SDK_ROOT}/platforms)
export PYTHON=/usr/bin/python2
- ndkPlatform=$(get_last ${ANDROID_NDK_ROOT}/platforms)
+ ndkPlatform=$(get_last_platform ${ANDROID_NDK_ROOT}/platforms)
_pref=/opt/${_pkgname}/${pkgver}/${android_arch}
configue_opts="
@@ -130,10 +127,6 @@ build() {
# Platform specific patches
case "$android_arch" in
- mips)
- configue_opts+="
- -skip qt3d"
- ;;
x86)
configue_opts+="
-no-sql-mysql