summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorTad Fisher2017-08-15 09:58:59 -0700
committerTad Fisher2017-08-15 09:58:59 -0700
commit1f5074e30cbd339725927a27b5893ed5f5dfd226 (patch)
tree63793dacc6fdf34ff7196de04bcbb64874a52a7e /PKGBUILD
parent97aaf44bab9d024af98c0bb24b7f0e74cd9e2d9a (diff)
downloadaur-1f5074e30cbd339725927a27b5893ed5f5dfd226.tar.gz
3.0 Beta 2
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 13731f1e75b8..5c0198eb7fc1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,22 +7,23 @@
# Contributor: Lubomir 'Kuci' Kucera <kuci24-at-gmail-dot-com>
pkgname=android-studio-beta
-pkgver=2.3.2.0
+pkgver=3.0.0.10
pkgrel=1
-_build=162.3934792
+_build=171.4263559
pkgdesc="The Official Android IDE (Beta branch)"
arch=('i686' 'x86_64')
url="http://tools.android.com/"
license=('APACHE')
-makedepends=('unzip')
-depends=('alsa-lib' 'freetype2' 'libxrender' 'libxtst')
+makedepends=('unzip' 'zip')
+depends=('freetype2' 'libxrender' 'libxtst')
optdepends=('gtk2: GTK+ look and feel'
'libgl: emulator support')
options=('!strip')
source=("https://dl.google.com/dl/android/studio/ide-zips/$pkgver/android-studio-ide-$_build-linux.zip"
"$pkgname.desktop")
-sha256sums=('6e33a232466820a15c884af9faefab772b8267ede056aaedb63f291ceb5e95a7'
- '71a104afc4bd0adb9dff46910e444e1dc1fc238eaf4e67c3793a829d19a720c2')
+sha256sums=('9c109f5cb3732cd9c31edb94657c10ba47c3cb4229ac4ff76a4683a27032ca2f'
+ '60edb7937f6c0fd1ad724574ff3c63fa69cedd2fdfcedf788f39a443c76743b6')
+
if [ "$CARCH" = "i686" ]; then
depends+=('java-environment')
@@ -31,12 +32,19 @@ fi
package() {
cd $srcdir/android-studio
- # application stuff
+ # Change the product name to produce a unique WM_CLASS attribute.
+ mkdir -p idea
+ unzip -p lib/resources.jar idea/AndroidStudioApplicationInfo.xml \
+ | sed "s/\"Studio\"/\"Studio Beta\"/" >idea/AndroidStudioApplicationInfo.xml
+ zip -r lib/resources.jar idea
+ rm -r idea
+
+ # Install the application.
install -d $pkgdir/{opt/$pkgname,usr/bin}
cp -a bin gradle lib jre plugins $pkgdir/opt/$pkgname
ln -s /opt/$pkgname/bin/studio.sh $pkgdir/usr/bin/$pkgname
- # Add the icon and desktop file
+ # Add the icon and desktop file.
install -Dm644 bin/studio.png $pkgdir/usr/share/pixmaps/$pkgname.png
install -Dm644 $srcdir/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop