summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGonzalo Exequiel Pedone2024-03-17 17:52:29 -0300
committerGonzalo Exequiel Pedone2024-03-17 17:52:29 -0300
commitfd5fb88d1dbfd9cc32401906ed060d5d91c98e73 (patch)
tree603d99d37273b94dd82519f6059038bc53fb1c0b /PKGBUILD
parent848a980d3b85e0e6f3bc7405d1ebb5ca2422ac70 (diff)
downloadaur-android-x86-64-libunistring.tar.gz
Disable pthread_atfork usage.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 28530eaade08..868ca70532ce 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,15 @@ _android_arch=x86-64
pkgname=android-${_android_arch}-libunistring
pkgver=1.1
-pkgrel=1
-pkgdesc="Library for manipulating Unicode strings and C strings (android)"
+pkgrel=2
arch=('any')
+pkgdesc="Library for manipulating Unicode strings and C strings (Android, ${_android_arch})"
url="https://www.gnu.org/software/libunistring/"
license=('GPL')
depends=('android-ndk'
"android-${_android_arch}-libiconv")
-options=(!strip !buildflags staticlibs !emptydirs)
makedepends=('android-configure')
+options=(!strip !buildflags staticlibs !emptydirs)
source=("https://ftp.gnu.org/gnu/libunistring/libunistring-${pkgver}.tar.xz"{,.sig})
validpgpkeys=('462225C3B46F34879FC8496CD605848ED7E69871' # Daiki Ueno <ueno@unixuser.org>
'9001B85AF9E1B83DF1BDA942F5BE8B267C6A406D') # Bruno Haible (Open Source Development) <bruno@clisp.org>
@@ -25,6 +25,8 @@ build() {
cd "${srcdir}"/libunistring-${pkgver}
source android-env ${_android_arch}
+ export ac_cv_func_pthread_atfork=no
+
android-${_android_arch}-configure
make $MAKEFLAGS
}