summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMartchus2022-06-22 23:00:33 +0200
committerMartchus2022-06-22 23:00:33 +0200
commit3491288dc2b9238bc00d39c96ae3338b5e5cc70b (patch)
tree9090f6aed91d55d2efb8816713c9f2910f2416d7 /PKGBUILD
parent68e894695d9c6ac17cf3831593466e88ad22ef7d (diff)
downloadaur-3491288dc2b9238bc00d39c96ae3338b5e5cc70b.tar.gz
Update to 1.1.1p
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 6 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3516b168fd4..b11833d5122a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@ _pkg_arch=x86
_android_arch=x86
_android_platform_arch=arch-x86
_pkgname=openssl
-_ver=1.1.1i
+_ver=1.1.1p
_patchname=15-android_conf
pkgname=android-$_pkg_arch-$_pkgname
# use a pacman compatible version scheme
pkgver=${_ver/[a-z]/.${_ver//[0-9.]/}}
-pkgrel=2
+pkgrel=1
pkgdesc="The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (Android, $_pkg_arch)"
arch=('any')
url='https://www.openssl.org'
@@ -21,11 +21,9 @@ depends=('android-sdk' 'android-ndk')
makedepends=('android-environment' 'android-sdk-build-tools')
conflicts=("android-$_pkgname-$_android_arch")
replaces=("android-$_pkgname-$_android_arch")
-source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc}
- "${_patchname}.patch")
-sha256sums=('e8be6a35fe41d10603c3cc635e93289ed00bf34b79671a3a4de64fcee00d5242'
- 'SKIP'
- '8ed3b78e8d6e5766595ae5ad6503cf0d21de4300d90aae556c7786f07ed9fdfb')
+source=("https://www.openssl.org/source/${_pkgname}-${_ver}.tar.gz"{,.asc})
+sha256sums=('bf61b62aaa66c7c7639942a94de4c9ae8280c08f17d4eac2e44644d9fc8ace6f'
+ 'SKIP')
validpgpkeys=('8657ABB260F056B1E5190839D9C4D26D0E604491'
'7953AC1FBC3DC8B3B292393ED5E9E43F7DF9EE8C')
@@ -34,17 +32,10 @@ build() {
source android-env ${_pkg_arch}
export PATH="${ANDROID_TOOLCHAIN}/bin:${PATH}"
- # Configure configuration script for android that shipped with openssl
- # 1.1.1i does not account for the removal of the $ndk/platforms directory in
- # android-ndk r22.
- patch -Np1 < "${srcdir}/${_patchname}.patch"
-
- # don't use -mandroid flag (Clang as provided by the NDK does not like it)
- sed -i -e 's/-mandroid//' Configurations/15-android.conf
-
./Configure \
--prefix="${ANDROID_PREFIX}" \
--openssldir="${ANDROID_PREFIX}" \
+ -U__ANDROID_API__ \
-D__ANDROID_API__="${ANDROID_MINIMUM_PLATFORM}" \
-Wl,--no-allow-shlib-undefined \
-Wl,--no-undefined \