summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authoreveryone2023-03-22 21:19:41 -0700
committereveryone2023-03-22 21:19:41 -0700
commitebe889c79856df1cd5ac553f309f0392855a5a78 (patch)
tree2e5edfb32a3adafb649d27ebc817a90c6a86f7b6 /PKGBUILD
parent1862c6dd1fc8139e2d5085291ae46b6c65a54d35 (diff)
downloadaur-ebe889c79856df1cd5ac553f309f0392855a5a78.tar.gz
update PKGBUILD to use new compilation steps
- remove launch script
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD45
1 files changed, 26 insertions, 19 deletions
diff --git a/PKGBUILD b/PKGBUILD
index aa158524d9de..59285973de61 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,31 @@
# Maintainer: DrakeTDL <everyone@disroot.org>
pkgname="an-anime-game-launcher-git"
_pkgname="${pkgname%-git}"
-pkgver=2.3.8.r23.g6a4afb1
-pkgrel=2
+pkgver=3.2.1.r7.g711cc82
+pkgrel=1
pkgdesc="A Launcher for a specific anime game with auto-patching, discord rpc and time tracking"
arch=("x86_64")
url="https://github.com/an-anime-team/an-anime-game-launcher"
license=("GPL3")
groups=()
-depends=(libayatana-appindicator tar unzip xdelta3 cabextract git curl iputils webkit2gtk libnotify)
-makedepends=(yarn)
+depends=(
+ cabextract
+ curl
+ git
+ glibc
+ gtk4
+ iputils
+ libadwaita
+ tar
+ unzip
+ xdelta3
+)
+makedepends=(rust)
checkdepends=()
optdepends=(
"mangohud: FPS Hud/GUI"
- "vkbasalt: Custom shaders (install this and reshade-shaders-git)"
- "reshade-shaders-git: Required by vkBasalt config files (install this and vkbasalt)"
"gamemode: Game Optimizations"
+ "gamescope: a tool from Valve that allows for games to run in an isolated Xwayland instance"
)
provides=()
conflicts=()
@@ -25,15 +35,12 @@ options=()
install=
changelog=
source=(
- # "${pkgname}"::"git+${url}"
"git+https://github.com/an-anime-team/an-anime-game-launcher"
- "${_pkgname}.sh"
"${_pkgname}.desktop"
)
noextract=()
sha256sums=(
SKIP
- "d47f8defce9030bc807e1f573cc024e2523e31a52638cf11f29400f252d7fa57"
"3bb15b29fd47e60ead712a67046daf42bd0ba5547d379ead6ea9bba37ea7b137"
)
@@ -44,25 +51,25 @@ pkgver() {
prepare() {
cd "${_pkgname}"
- yarn
- yarn neu update
+ git switch next
+ git submodule update --init --recursive --single-branch
}
build() {
cd "${_pkgname}"
- yarn build
+ cargo build --release
}
package() {
cd "${_pkgname}"
- install -Dm755 "${srcdir}/an-anime-game-launcher.sh" "${pkgdir}/usr/bin/${_pkgname}"
- install -Dm644 "${srcdir}/an-anime-game-launcher.desktop" -t "${pkgdir}/usr/share/applications"
- install -Dm644 "dist/${_pkgname}/public/icons/256x256.png" "${pkgdir}/usr/share/pixmaps/${_pkgname}.png"
+ install -dm755 "${pkgdir}/usr/lib/${_pkgname}"
+ install -dm755 "${pkgdir}/usr/bin/"
- install -Dm644 "dist/${_pkgname}/resources.neu" "${pkgdir}/usr/share/${_pkgname}/resources.neu"
- install -Dm755 "dist/${_pkgname}/${_pkgname}-linux_x64" "${pkgdir}/usr/share/${_pkgname}/${_pkgname}"
+ cp target/release/anime-game-launcher "${pkgdir}/usr/lib/${_pkgname}/${_pkgname}"
+ ln -s "${pkgdir}/usr/lib/${_pkgname}/${_pkgname}" "${pkgdir}/usr/bin/${_pkgname}"
- cd "dist/${_pkgname}/public"
- find * -type f -exec install -Dm 755 {} "${pkgdir}/usr/share/${_pkgname}/public/"{} \;
+ install -Dm644 "assets/images/icon.png" "${pkgdir}/usr/share/pixmaps/an-anime-game-launcher.png"
+ install -Dm644 "assets/images/icon.png" "${pkgdir}/usr/share/icons/moe.launcher.an-anime-game-launcher.png"
+ install -Dm644 "${srcdir}/an-anime-game-launcher.desktop" -t "${pkgdir}/usr/share/applications"
}