summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorSeth Barberee2016-07-19 13:02:48 -0500
committerSeth Barberee2016-07-19 13:02:48 -0500
commitbff3dad9ddb0aeb30f01596a9d5b1ab71a43a187 (patch)
tree8c78a1aef274617b6ca698a123d4bf1958b948dd /PKGBUILD
downloadaur-bff3dad9ddb0aeb30f01596a9d5b1ab71a43a187.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4261b84b5240
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=animewatch-pyqt4
+_pkgname=AnimeWatch
+pkgver=2.4.1
+pkgrel=2
+pkgdesc="An Audio/Video Manager and Front End for mpv/mplayer with special emphasis on Anime Collection based on PyQt4"
+arch=(any)
+conflicts=('animewatch-pyqt5')
+license=('GPL3')
+depends=('python' 'python-pyqt4' 'python-pycurl' 'python-urllib3' 'curl' 'libnotify' 'python-dbus'
+ 'python-beautifulsoup4' 'python-psutil' 'python-pillow' 'python-lxml' 'mpv' 'mplayer' 'ffmpegthumbnailer' 'sqlite3' 'python-pytaglib')
+
+#source=("git+https://github.com/kanishka-linux/AnimeWatch.git")
+source=("https://github.com/kanishka-linux/"${pkgname}"/archive/v"${pkgver}-${pkgrel}".zip")
+md5sums=('SKIP')
+_gitname=AnimeWatch-PyQt4-Stable
+
+
+package() {
+
+ _bpath="${srcdir}/${pkgname}-${pkgver}-${pkgrel}/${_gitname}"
+
+ install -d "${pkgdir}/usr/share/${_pkgname}/"
+ install -d "${pkgdir}/usr/share/${_pkgname}/Plugins/"
+ install -d "${pkgdir}/usr/share/applications/"
+ install -d "${pkgdir}/usr/bin/"
+
+ install -Dm755 "${_bpath}"/{animeWatch.py,musicArtist.py,adb.py,1.png,input.conf,default.jpg,default.html,introspect.xml,stream.png} "${pkgdir}/usr/share/${_pkgname}/"
+ cat "${_bpath}/AnimeWatch.desktop" | sed 's/Exec=/Exec=python -B \/usr\/share\/AnimeWatch\/animeWatch.py \%u/g' > "${pkgdir}/usr/share/applications/AnimeWatch.desktop"
+ echo '#!/bin/bash' > "${pkgdir}/usr/bin/anime-watch"
+ echo 'if [ -z "$1" ]; then python -B /usr/share/AnimeWatch/animeWatch.py; else python -B /usr/share/AnimeWatch/animeWatch.py "$(pwd)/$1"; fi' >> "${pkgdir}/usr/bin/anime-watch"
+ chmod +x "${pkgdir}/usr/bin/anime-watch"
+
+ for file in "${_bpath}/Plugins/"*;do
+ nm=$(echo $file | rev | cut -d'/' -f1 | rev)
+ if [ $nm != "installPlugins.py" ];then
+ #echo $nm
+ install -Dm755 "$file" "${pkgdir}/usr/share/${_pkgname}/Plugins/"
+ fi
+ done
+}