summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052023-08-02 10:52:50 +0800
committerzxp198210052023-08-02 10:52:50 +0800
commit21e45c28b5e0b43d5c60a6bdbf192a22fa738f3e (patch)
tree59594bce84d10402d53e43d9fc85847e302329ad /PKGBUILD
parent9f2af55fef842b32bcbf3cb992655ce957035b06 (diff)
downloadaur-21e45c28b5e0b43d5c60a6bdbf192a22fa738f3e.tar.gz
optimized PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 758a8176625a..d1de3f311eff 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,19 @@
# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
pkgname="aniship-bin"
-pkgver=0.0.4
+pkgver=0.0.4.2
pkgrel=1
pkgdesc="A convenient and functional unofficial client that allows for easy viewing of anime on PCs and laptops."
arch=('x86_64')
url="https://t.me/aniship"
_githuburl="https://github.com/progzone122/AniShip"
license=('custom')
+provides=("${pkgname%-bin}")
conflicts=("${pkgname%-bin}")
-depends=('electron' 'gcc-libs' 'glibc')
-source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}-night/setup-${pkgver}.AppImage"
+depends=('bash' 'electron16' 'gcc-libs' 'glibc')
+source=("${pkgname%-bin}-${pkgver}.AppImage::${_githuburl}/releases/download/v${pkgver}night/setup-0.0.4-2.AppImage"
"${pkgname%-bin}.sh")
-sha256sums=('344a3c493d52a33a1cc522e401f760fce653357ac3dc726b458739d6b1038f2b'
- 'dda7e4f0b91ac9ee3b9aa5d72f985899234684e7973442ce9cdc4905da16b72e')
+sha256sums=('1fbe0e6388982d71268c4f4f04bf7c3f82ac0a6dee8310f8599d93be565525d2'
+ '5fb5356053631c4ac7ad2ab51f0f4738569d918b9c4407f7db64ba05d7be8896')
prepare() {
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null