summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexBocken2022-12-16 16:50:16 +0100
committerAlexBocken2022-12-16 16:50:16 +0100
commit42f510a8a5cda94d3ba33f3c260401d84dd6e68e (patch)
treecb46aaa13a26fd6623c854812070cdea30b6b3bf /PKGBUILD
parent505d4940865477d943825946f20112e49043ae3f (diff)
downloadaur-42f510a8a5cda94d3ba33f3c260401d84dd6e68e.tar.gz
add python-installer to mkdps, TODO comments
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 34c9283e591f..c34523eeb57f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,12 +44,15 @@ makedepends=(
'git'
'ninja'
+ 'python-installer'
)
optdepends=(
'lame: record sound'
'mpv: play sound. prefered over mplayer'
'mplayer: play sound'
)
+# using the tag tarballs does not work with the new (>= 2.1.55) build process.
+# the '.git' folder is not included in those but is required for a sucessful build
source=("anki-${pkgver}::git+https://github.com/ankitects/anki#tag=${pkgver}"
"no-update.patch"
)
@@ -59,7 +62,7 @@ sha256sums=('SKIP'
prepare(){
cd "anki-$pkgver"
- # pro-actively prevent "module not found" error
+ # pro-actively prevent "module not found" error (TODO: verify whether still required)
[ -d ts/node_modules ] && rm -r ts/node_modules
patch -p1 < "$srcdir/no-update.patch"
}
@@ -75,6 +78,7 @@ package() {
python -m installer --destdir="$pkgdir" $file
done
+ # TODO: verify whether still required
find $pkgdir -iname __pycache__ | xargs -r rm -rf
find $pkgdir -iname direct_url.json | xargs -r rm -rf
}