summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAlexBocken2022-05-26 10:46:52 +0200
committerAlexBocken2022-05-26 10:46:52 +0200
commitbff73c294ed8ea1c5abf4dae5d6bb707782ba5eb (patch)
tree131df806092c6ddaf1c0e1f56ed22547d61bbd90 /PKGBUILD
parent9fe3588e53ef0877f79cf1f533c935c97e8692b1 (diff)
downloadaur-bff73c294ed8ea1c5abf4dae5d6bb707782ba5eb.tar.gz
clean bazel shutdown, drop stringcase dependency
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 11 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 89bb56e6bcae..dd769c9829c9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@
pkgname=anki
pkgver=2.1.52
-pkgrel=1
+pkgrel=2
pkgdesc="Helps you remember facts (like words/phrases in a foreign language) efficiently"
url="https://apps.ankiweb.net/"
license=('AGPL3')
@@ -29,7 +29,6 @@ depends=(
'python-protobuf'
'python-orjson'
'python-distro'
- 'python-stringcase'
# aqt
'python-send2trash'
@@ -66,6 +65,15 @@ sha256sums=('e2df0055ee27a432b8e479ef180e02d30f1bb9674ce7305fd51d680160e936f8'
'fc477627179cbc0f88190e05abe1256bf1e62367620331ddf574303356d21169'
)
+_bazel_build() {
+ bazel build -c opt wheels
+ _status=$?
+ bazel shutdown
+ if [[ $_status -gt 0 ]]; then
+ exit $_status # or call false
+ fi
+}
+
prepare(){
cd "anki-$pkgver"
# pro-actively prevent "module not found" error
@@ -90,7 +98,7 @@ If the build is failing retry the installation. This usually fixes the problem.
A too slow internet connection can also hinder the dependency fetching process because of hardcoded timeouts in bazel.
If the problem persists consider removing data in ~/.cache/bazel and your AUR manager cache (~/.cache/paru/clone/anki for paru) and retry again.
####################"
- bazel build -c opt wheels
+ _bazel_build
}
package() {