summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorKuklin István Alexander2022-06-19 20:22:20 +0200
committerKuklin István Alexander2022-06-19 20:22:20 +0200
commit445f1780bb7176e1e0daebf510a2f4bdca7ca5ba (patch)
treefa5bf1151237f87a62ba41671062cc972bfdc290 /PKGBUILD
parentedaf18ecc5c0e2ad53dfbd0b09334c3513de55df (diff)
downloadaur-445f1780bb7176e1e0daebf510a2f4bdca7ca5ba.tar.gz
2.1.53
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD24
1 files changed, 9 insertions, 15 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b7152679902d..af9fcb22bc7a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Maintainer: Kuklin István <kuklinistvan@zoho.com>
pkgname=anki-official-binary-bundle
-pkgver=2.1.49
+pkgver=2.1.53
pkgrel=1
epoch=
pkgdesc="The official binary shipped with the tested versions of the dependent libraries."
@@ -22,31 +22,25 @@ conflicts=('anki' 'anki-git')
replaces=()
backup=()
options=()
-install=
+install=$pkgname.install
changelog=
-topdirname="anki-$pkgver-linux"
+topdirname="anki-$pkgver-linux-qt6"
source=(
- "https://github.com/ankitects/anki/releases/download/${pkgver}/${topdirname}.tar.bz2"
+ "https://github.com/ankitects/anki/releases/download/${pkgver}/${topdirname}.tar.zst"
"install_sh.patch"
)
noextract=()
-md5sums=('d0c13ae7cf988358fb231645f6490088'
- '82d6fb7eb10ec0ae592093d89d8d5957')
+sha256sums=('c9739271c6f2bfbe248c98fd83d5ce8952301f21ac39f2c0504219294557ddfc'
+ '991297cb02434d753f55980205a22971ed98655b0f62f0104ae4692155355d8c')
validpgpkeys=()
prepare() {
- cd "$srcdir"
- ln -s "$topdirname" anki
- patch -p0 -i install_sh.patch anki/install.sh
- rm anki
-}
-
-build() {
- cd "$topdirname"
+ cd "$srcdir"/"$topdirname"
+ patch install.sh ../install_sh.patch
}
package() {
cd "$topdirname"
- PREFIX="$pkgdir"/usr/ ./install.sh
+ PREFIX="$pkgdir"/usr/ ./install.sh
}