summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShane2019-07-11 02:22:56 +0800
committerShane2019-07-11 02:22:56 +0800
commitdb4bd90ff536f2d054deb6114a2bcca318426653 (patch)
tree29ee93dd138762052adaf29db91fcbd61e9139b9 /PKGBUILD
parenteb9e942c3c9816a5c9270b5ab171c19d587947d1 (diff)
downloadaur-db4bd90ff536f2d054deb6114a2bcca318426653.tar.gz
添加LICENSE
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 11 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 72760490cea2..3e58a8b5cb49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# Maintainer: Shane Lyx <shanelyx@outlook.com>
+# Maintainer: Shane Lyx <shanelyx at outlook dot com>
pkgname=another-redis-desktop-manager
pkgver=1.2.4
pkgrel=1
@@ -6,22 +6,20 @@ pkgdesc="Another Redis Desktop Manager"
arch=("x86_64")
url="https://github.com/qishibo/AnotherRedisDesktopManager"
license=('MIT')
-depends=('aria2' 'libappindicator-sharp' 'libappindicator-gtk3' 'libappindicator-gtk2' 'gconf' 'libindicator-gtk3' 'libindicator-gtk2'
+depends=('libappindicator-sharp' 'libappindicator-gtk3' 'libappindicator-gtk2' 'gconf' 'libindicator-gtk3' 'libindicator-gtk2'
'libnotify' 'libxss' 'libxtst')
-DLAGENTS=('https::/usr/bin/aria2c -x 5 -c --disable-ipv6=true --check-certificate=false -o %o %u')
-
source=(
"https://github.com/qishibo/AnotherRedisDesktopManager/releases/download/v1.2.4/Another.Redis.Desktop.Manager.1.2.4.AppImage"
"another-redis-desktop-manager.desktop"
"another-redis-desktop-manager.png"
+ "LICENSE"
)
-md5sums=(
- "9818915d396b59af1037b17fd1c3460f"
- "SKIP"
- "SKIP"
-)
+md5sums=('9818915d396b59af1037b17fd1c3460f'
+ '11ac6e7e9d578a9ad0b548c3fc9a2527'
+ '3f7c15e66be6ffd8b70fbb50882fc0dd'
+ '74fd786ee05276f7550f94e8ed1bf495')
package(){
cd ${srcdir}
@@ -35,6 +33,10 @@ package(){
# icon
mkdir -p ${pkgdir}/usr/share/icons/hicolor/512x512/apps
install -Dm644 another-redis-desktop-manager.png ${pkgdir}/usr/share/icons/hicolor/512x512/apps/
+
+ #license
+ mkdir -p "${pkgdir}"/usr/share/licenses/${pkgname}
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/
}