summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorzxp198210052024-01-17 23:39:46 +0800
committerzxp198210052024-01-17 23:39:46 +0800
commitfa2b05ee1c7abfdbf60153e5a5c521566c561e2c (patch)
tree3f7334316ba04e28eea9e5c3ecb6d9f536d54f66 /PKGBUILD
parent2938757092a23aff8f2098ef626aff56a8d41181 (diff)
downloadaur-fa2b05ee1c7abfdbf60153e5a5c521566c561e2c.tar.gz
fix errors
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 2 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index db87fd939312..3512fc4baa8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,9 +12,6 @@ conflicts=("${pkgname%-bin}")
provides=("${pkgname%-bin}=${pkgver}")
depends=(
"electron${_electronversion}"
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
'libdbusmenu-glib'
'gtk2'
'dbus-glib'
@@ -27,7 +24,7 @@ source=(
)
sha256sums=('bf63908cef742f46b7d4c6b5a91593a373f88accc4f00ddb7740c527ccbfc2a3'
'49e1afe88ff863df075233daa348d313c1f77110de7d89794a6a9ae45b38c1b3'
- '8915ca75d453698df81f7f3305cce6869f4261d754d90f0c3724b73c7b24ca84')
+ 'd4272fed78cdcacd9edfb019134ac485d65b43f4d8c7a4179edbaed56af9b231')
build() {
sed -e "s|@electronversion@|${_electronversion}|" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -35,7 +32,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {