summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJeffrey Zhang2020-04-04 11:21:09 +0800
committerJeffrey Zhang2020-04-04 11:21:09 +0800
commit04edbfae5e1b51df0308c8d742871bd103d84ef2 (patch)
tree47080efdbe06c01c7cba7dea240cf2ef046eee72 /PKGBUILD
downloadaur-04edbfae5e1b51df0308c8d742871bd103d84ef2.tar.gz
init project
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0b23196e5e58
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Jeffrey Zhang <zhang.lei.fly@gmail.com>
+
+pkgname=ansible-runner
+pkgver=1.4.6
+pkgrel=1
+pkgdesc="A tool and python library that helps when interfacing with Ansible directly"
+arch=("any")
+url="https://github.com/ansible/ansible-runner"
+license=('Apache')
+depends=("python-psutil"
+ "python-pexpect"
+ "python-daemon"
+ "python-yaml"
+ "python-six")
+makedepends=('python-setuptools')
+source=("https://github.com/ansible/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('7a36fae4589daaea7bdc4c8f9b3ca8ffe05a170c737162214f419dd9d7488aa8')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+}