summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMichał Pajda2024-01-24 20:48:57 +0100
committerMichał Pajda2024-01-24 20:48:57 +0100
commit76af69159ddb22793a581a69c2cb2585f5a0ee95 (patch)
tree75c7ede00c0054ed4c33be8515b062ed6819d3d3 /PKGBUILD
downloadaur-76af69159ddb22793a581a69c2cb2585f5a0ee95.tar.gz
init anteater
Diffstat (limited to 'PKGBUILD')
-rwxr-xr-xPKGBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c10e8aea9766
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: Hubert Dej <hubert.dej@student.uj.edu.pl>
+# Contributor: Katzper Michno <katzper.michno@student.uj.edu.pl>
+# Contributor: Maciej Matys <maciej.matys@student.uj.edu.pl>
+# Contributor: Tomasz Mazur <tomasz.mazur@student.uj.edu.pl>
+#
+# Maintainer: Michał Pajda <m.pajda@student.uj.edu.pl>
+# Maintainer: Michał Horodecki <michal.horodecki@student.uj.edu.pl>
+# Maintainer: Dominik Matuszek <dominik.matuszek@student.uj.edu.pl>
+# Maintainer: Kacper Topolski <kacper.topolski@student.uj.edu.pl>
+pkgname=anteater
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="Tool for tracing program output and creating structured logs using plain text or html."
+arch=('x86_64')
+url="https://github.com/Student-Team-Projects/Debugger.git"
+license=('GPL-3.0-or-later')
+depends=('libbpf' 'bpf' 'boost')
+makedepends=('make' 'clang')
+source=("debugger-2.0.0.zip::https://github.com/Student-Team-Projects/debugger/archive/refs/tags/v2.0.0.zip")
+md5sums=("SKIP")
+noextract=()
+
+build() {
+ cd "debugger-2.0.0"
+ make build
+}
+
+package() {
+ cd "debugger-2.0.0"
+ mkdir -p $pkgdir/usr/bin
+ cp bin/main $pkgdir/usr/bin/anteater
+ chown root $pkgdir/usr/bin/anteater
+ chmod 4755 $pkgdir/usr/bin/anteater
+}