summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorBryn Edwards2019-03-19 15:03:35 +0000
committerBryn Edwards2019-03-19 15:03:35 +0000
commitc9304ba2befb9d3da772800eb6a18ea816e8c844 (patch)
tree118efe81019f713e4a6edb0cdd02a788ad1767c5 /PKGBUILD
parent5ce176218d3655d47431124cdcb7cd476a4eac05 (diff)
downloadaur-c9304ba2befb9d3da772800eb6a18ea816e8c844.tar.gz
Simplify build method
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 6 insertions, 13 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 68cca009e350..716a73cf2eb8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=antibody
pkgver=4.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="A shell plugin manager."
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
url="https://getantibody.github.io/"
@@ -11,31 +11,24 @@ depends=('git')
makedepends=('go')
source=("https://github.com/getantibody/antibody/archive/v${pkgver}.tar.gz")
sha256sums=('421ef6b7759910fe042002a4b65c9e06fcac374d20d85a04146b406edc93fb32')
-_repodir=(".go/src")
prepare() {
- export GOPATH="$srcdir/.go"
- mkdir -p "$srcdir/$_repodir"
- ln -snf "$srcdir/$pkgname-$pkgver" \
- "$srcdir/$_repodir/$pkgname"
- cd "$srcdir/$_repodir/$pkgname"
+ cd "$pkgname-$pkgver"
sed -i "25s/dev/$pkgver/" "main.go"
}
build() {
- export GOPATH="$srcdir/.go"
- cd "$srcdir/$_repodir/$pkgname"
- make build
+ cd "$pkgname-$pkgver"
+ go build .
}
check() {
- export GOPATH="$srcdir/.go"
- cd "$srcdir/$_repodir/$pkgname"
+ cd "$pkgname-$pkgver"
make test
}
package() {
- cd "$srcdir/$pkgname-$pkgver"
+ cd "$pkgname-$pkgver"
install -Dm755 "$pkgname" "$pkgdir/usr/bin/$pkgname"
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}