summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJulian Xhokaxhiu2018-11-25 21:24:54 +0100
committerJulian Xhokaxhiu2018-11-25 21:24:54 +0100
commit829e72ee142d65e2a869d566def443c456acff57 (patch)
tree17506b9979d73b64911aa4469013beb3847cb102 /PKGBUILD
parentf7371b75f6571e50d6a9d96c54a9c31d765b9642 (diff)
downloadaur-829e72ee142d65e2a869d566def443c456acff57.tar.gz
4.0.2-1
Refine the PKGBUILD making it lightweight Add support for native armv7 binary
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD29
1 files changed, 8 insertions, 21 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 31cb9ec13fc3..4c84d87d089a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,25 @@
#Maintainer: Julian Xhokaxhiu <info at julianxhokaxhiu dot com>
pkgname=antibody-bin
-pkgver=4.0.0
-pkgrel=2
+pkgver=4.0.2
+pkgrel=1
pkgdesc="Antibody is a shell plugin manager made from the ground up thinking about performance"
arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
conflicts=('antibody')
source_i686=("https://github.com/getantibody/antibody/releases/download/v$pkgver/antibody_Linux_i386.tar.gz")
source_x86_64=("https://github.com/getantibody/antibody/releases/download/v$pkgver/antibody_Linux_x86_64.tar.gz")
source_armv6h=("https://github.com/getantibody/antibody/releases/download/v$pkgver/antibody_Linux_armv6.tar.gz")
-source_armv7h=("https://github.com/getantibody/antibody/releases/download/v$pkgver/antibody_Linux_armv6.tar.gz")
+source_armv7h=("https://github.com/getantibody/antibody/releases/download/v$pkgver/antibody_Linux_armv7.tar.gz")
source_aarch64=("https://github.com/getantibody/antibody/releases/download/v$pkgver/antibody_Linux_arm64.tar.gz")
url="https://github.com/getantibody/antibody"
license=("MIT")
-sha256sums_i686=("2854247291679b3305133f84c96be355f0397d99400286811a009006c6ff506c")
-sha256sums_x86_64=("a1c69b7a19425a6e15741cf280bc14b1f1d7085c426395fe59463544abbb8912")
-sha256sums_armv6h=("e3c7985a72153b3a134f13305b4cc76af0f60aeb968a1edd6250454cb57505ea")
-sha256sums_armv7h=("e3c7985a72153b3a134f13305b4cc76af0f60aeb968a1edd6250454cb57505ea")
-sha256sums_aarch64=("00d88a182cab434891281019b43225472d2b9caf48ea9a1c6c6e5df3dae895a3")
+sha256sums_i686=("ddbabb04a73c138c222e40d76a5a3223e25604802992a3eb8681e60889adae55")
+sha256sums_x86_64=("774196b5c349987b2bd5b5bdb679175ab581cbd7590654139958560cb7ed5685")
+sha256sums_armv6h=("f7aa109fd081681c21c8c6dfcc14ec4dfbbcd295755c7760cd746ebc6757a222")
+sha256sums_armv7h=("3df2957b85c44474f48631bd6fd185ba0276ddae0d2e8d12cb0c1f1369baa951")
+sha256sums_aarch64=("e5e98fec324ab14d87791203f705c7f5828da66471023fa385738fa62a63c4a5")
package() {
- _ARCH=""
-
- # Update the architecture name based on the current one running this PKGBUILD
- if [ "$CARCH" == "i686" ]; then
- _ARCH="i386"
- elif [ "$CARCH" == "x86_64" ]; then
- _ARCH="x86_64"
- elif [ "$CARCH" == "aarch64" ]; then
- _ARCH="arm64"
- else
- _ARCH="armv6"
- fi
-
# Unpack, flag as executable and move to the right directory
install -Dm755 "antibody" "$pkgdir/usr/bin/antibody"
install -Dm644 "LICENSE.md" "$pkgdir/usr/share/licenses/antibody/LICENSE"