summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorGiovanni Harting2021-05-08 18:16:54 +0200
committerGiovanni Harting2021-05-08 18:16:54 +0200
commitf4a56d06ac9876efdd2da5549272a189f6482bd0 (patch)
tree8c0270db4b29e28f232f640839dd90d018d4944b /PKGBUILD
downloadaur-f4a56d06ac9876efdd2da5549272a189f6482bd0.tar.gz
Initial upload: antidot 0.6.2-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4633ea2aa583
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Giovanni Harting <539@idlegandalf.com>
+
+pkgname=antidot
+pkgver=0.6.2
+pkgrel=1
+pkgdesc='Cleans up your $HOME from those pesky dotfiles'
+arch=('x86_64')
+url="https://github.com/doron-cohen/$pkgname"
+license=('MIT')
+depends=('glibc')
+makedepends=('go')
+source=("https://github.com/doron-cohen/$pkgname/archive/refs/tags/v$pkgver.tar.gz")
+b2sums=('a203c50f8e5f407769d3897ac6965c01b8291757bc0b2ce2e2b6a0b996dabf9e0fed09e69c6db7157bed48171bdeb9d1fcb4dd6b6e2b2bbd5d6f7b3264f12202')
+
+prepare(){
+ cd "$pkgname-$pkgver"
+ mkdir -p build/
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm755 build/$pkgname "$pkgdir"/usr/bin/$pkgname
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}
+