summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfrealgagu2018-12-14 12:03:35 -0500
committerfrealgagu2018-12-14 12:03:35 -0500
commit7e5854b85b27a82aee9c042491bd3df28ee4dc09 (patch)
treea4dd582b359386eaf1e4205165f2baffd0c2411f /PKGBUILD
parent2d876e9c925890003c66caddbb2c3a46b07f42c7 (diff)
downloadaur-7e5854b85b27a82aee9c042491bd3df28ee4dc09.tar.gz
Fixing library path which was pointing to /urs/lib instead of /usr/lib
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD10
1 files changed, 6 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 2c6ec0f58162..31b137b9ec7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,12 +5,12 @@
pkgname=antimicro
pkgver=2.24.1
-pkgrel=1
+pkgrel=2
pkgdesc="Graphical program used to map keyboard keys and mouse controls to a gamepad"
arch=("i686" "x86_64")
url="https://github.com/juliagoda/${pkgname}"
license=("GPL3")
-depends=("desktop-file-utils" "libxtst" "qt5-base" "sdl2")
+depends=("desktop-file-utils" "hicolor-icon-theme" "libxtst" "qt5-base" "sdl2")
makedepends=("cmake" "extra-cmake-modules" "gettext" "itstool" "qt5-tools")
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/juliagoda/${pkgname}/archive/${pkgver}.tar.gz")
sha256sums=("1a7f8693b2f969426a1ae1177af9d76389274308ae2f713a694df7c616369b31")
@@ -20,10 +20,12 @@ build() {
cmake \
-DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DUSE_SDL_2=ON \
- -DWITH_XTEST=ON \
+ -DAPPDATA=ON \
-DWITH_UINPUT=ON \
- -DAPPDATA=ON
+ -DWITH_X11=ON \
+ -DWITH_XTEST=ON
make
}