summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorThomas Nordenmark2015-06-26 04:30:38 +0200
committerThomas Nordenmark2015-06-26 04:30:38 +0200
commit9ff4b59fd28843dd2d0ff2da092353e74273d208 (patch)
tree27b93851a9471dcd8d0495b4fe5cfe4543819d2a /PKGBUILD
downloadaur-9ff4b59fd28843dd2d0ff2da092353e74273d208.tar.gz
Initial import to AUR4
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..adb4e2ffa541
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Travis Nickles <nickles.travis@gmail.com>
+# Contributor: Travis Nickles <nickles.travis@gmail.com>
+
+pkgname=antimicro
+pkgver=2.14
+pkgrel=1
+pkgdesc="Graphical program used to map keyboard keys and mouse controls to gamepad buttons"
+arch=('i686' 'x86_64')
+url="https://github.com/Ryochan7/antimicro"
+license=('GPL3')
+groups=()
+depends=('libxkbcommon-x11' 'libxtst' 'qt5-base' 'sdl2')
+makedepends=('cmake' 'gettext' 'itstool' 'qt5-tools')
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install="${pkgname}.install"
+source=("https://github.com/Ryochan7/antimicro/archive/${pkgver}.tar.gz")
+md5sums=("66aecb2cb11070fb53e23d50196b7e97")
+noextract=()
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+
+ mkdir -p build && cd build
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DUSE_SDL_2=ON -DWITH_XTEST=ON \
+ -DWITH_UINPUT=ON -DAPPDATA=ON ..
+ make || return 1
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
+
+ make DESTDIR="${pkgdir}" install
+}