summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorYaohan Chen2022-05-28 14:33:35 -0400
committerYaohan Chen2022-05-28 14:33:35 -0400
commita1943f548818aa8c07073f43693e8876f0e3cbb1 (patch)
tree2176fe00990d68a22a335f0338535df5da3b5d3b /PKGBUILD
parent2a95caac36b4066bbeaeb8d21d1a75cef71401f8 (diff)
downloadaur-a1943f548818aa8c07073f43693e8876f0e3cbb1.tar.gz
Fix build
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index b0f9ebb425a1..aa30c37f4ed0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Yaohan Chen <yaohan.chen@gmail.com>
pkgname=anura-git
-pkgver=0.0.3619.ge4a2f2e7
+pkgver=0.0.3849.gfc9853001
pkgrel=1
pkgdesc="A fully-featured game engine, the tech behind the spectacular Frogatto & Friends."
arch=(i686 x86_64)
@@ -10,13 +10,12 @@ depends=(libgl mesa glew cairo sdl2 sdl2_image sdl2_ttf sdl2_mixer libpng boost-
optdepends=('frogatto-git: the default game module'
'box2d: box2d physics')
makedepends=(git boost)
-source=('git+https://github.com/anura-engine/anura.git#branch=trunk'
+source=('git+https://github.com/anura-engine/anura.git#branch=buildsystem-upgrade'
'git+https://github.com/sweetkristas/imgui.git'
anura.sh)
md5sums=('SKIP'
'SKIP'
'15f4c03c2404bcfd7618b8f9e0c850ba')
-install=anura.install
_gitname=anura
@@ -43,7 +42,7 @@ build() {
cd $_gitname
# USE_CCACHE=no to honor makepkg's ccache setting.
- make USE_CCACHE=no anura
+ make -e USE_CCACHE=no CXXFLAGS='-Wno-error=return-type' anura
}
package() {