summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEdvin Bryntesson2023-04-05 15:35:12 +0200
committerEdvin Bryntesson2023-04-05 15:35:12 +0200
commit1f00c86b04724fed7c8743385953d3722ade994f (patch)
treeb73e779070bc16de605f01b33bc7339acec7909a /PKGBUILD
downloadaur-1f00c86b04724fed7c8743385953d3722ade994f.tar.gz
made the anyrun PKGBUILD
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD40
1 files changed, 40 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c9bd9fe8ed77
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Edvin Bryntesson <aur@edvinbryntesson.se>
+_pkgname="anyrun"
+pkgname="${_pkgname}-git"
+pkgver=r22.795bb00
+pkgrel=1
+pkgdesc="A rust-based wayland native krunner-like runner, made with customizability in mind."
+arch=("x86_64")
+url="github.com/Kirottu/anyrun"
+license=('GPL3')
+depends=(gtk-layer-shell gtk3 pango cairo gdk-pixbuf2 glib2)
+makedepends=(git cargo)
+source=("${_pkgname}-$pkgver::git+https://$url.git")
+sha256sums=('SKIP')
+pkgver() {
+ cd "${_pkgname}-$pkgver"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+prepare() {
+ cd "${_pkgname}-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+build() {
+ cd "${srcdir}/${_pkgname}-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release --all-features
+}
+
+package() {
+ cd "${_pkgname}-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}"
+ mkdir -p "$pkgdir/etc/anyrun/plugins"
+ printf "Config( \n width: 800, \n position: Top, \n plugins: [ \n 'libapplications.so', \n 'libsymbols.so', \n 'libshell.so', \n 'libtranslate.so', \n ], \n)" > "$pkgdir/etc/anyrun/config.ron"
+ touch "$pkgdir/etc/anyrun/style.css"
+ cp target/release/*.so "$pkgdir/etc/anyrun/plugins/"
+}