summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorEdvin Bryntesson2023-04-14 16:58:26 +0200
committerEdvin Bryntesson2023-04-14 16:58:26 +0200
commit22e024c80569c26f6a4cdd47205b2da007893853 (patch)
tree8c0596266960a84394b744aeddd9e2988b2da70b /PKGBUILD
parent1d89162e1c1d697abb597bd4105de3582db5949d (diff)
downloadaur-22e024c80569c26f6a4cdd47205b2da007893853.tar.gz
now grabbing default config.ron from file and same for style.css
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD7
1 files changed, 4 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 46cca01d0358..8a6d7dad97ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Edvin Bryntesson <aur@edvinbryntesson.se>
_pkgname="anyrun"
pkgname="${_pkgname}-git"
-pkgver=r35.7a7fb55
+pkgver=r49.ca8255c
pkgrel=2
pkgdesc="A rust-based wayland native krunner-like runner, made with customizability in mind."
arch=("x86_64")
@@ -9,7 +9,7 @@ url="github.com/Kirottu/anyrun"
license=('GPL3')
depends=(gtk-layer-shell gtk3 pango cairo gdk-pixbuf2 glib2)
makedepends=(git cargo)
-backup=("etc/anyrun/config.ron")
+backup=("etc/anyrun/config.ron" "etc/anyrun/style.css")
source=("${_pkgname}::git+https://$url.git")
sha256sums=('SKIP')
pkgver() {
@@ -35,6 +35,7 @@ package() {
export RUSTUP_TOOLCHAIN=stable
install -Dm0755 -t "$pkgdir/usr/bin/" "target/release/${_pkgname}"
mkdir -p "$pkgdir/etc/anyrun/plugins"
- printf "Config( \n width: 800, \n position: Top, \n hide_icons: false, \n plugins: [ \n 'libapplications.so', \n 'libsymbols.so', \n 'libshell.so', \n 'libtranslate.so', \n ], \n)" > "$pkgdir/etc/anyrun/config.ron"
+ cp examples/config.ron "$pkgdir/etc/anyrun/config.ron"
+ cp anyrun/res/style.css "$pkgdir/etc/anyrun/style.css"
cp target/release/*.so "$pkgdir/etc/anyrun/plugins/"
}