summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorShohei Kusakata2015-08-12 00:57:29 +0900
committerShohei Kusakata2015-08-12 00:57:29 +0900
commit68c7230cc9abd99eebe2aa7eeec4032da30dbeea (patch)
tree1e91f996c553e6f4f2943c12f9eb9839ca917807 /PKGBUILD
downloadaur-68c7230cc9abd99eebe2aa7eeec4032da30dbeea.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c5923b41f077
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: kusakata <shohei atmark kusakata period com>
+
+pkgname=aobook
+pkgver=1.0.1
+_sfver=62557
+pkgrel=1
+pkgdesc='Aozora Bunko text viewer'
+arch=('i686' 'x86_64')
+url="http://azsky2.html.xdomain.jp/linux/aobook/"
+license=('BSD')
+depends=('fontconfig' 'hicolor-icon-theme' 'libjpeg-turbo' 'libx11' 'libxext' 'xdg-utils')
+install=aobook.install
+source=("http://dl.osdn.jp/aobook/${_sfver}/aobook-${pkgver}.tar.bz2")
+
+build() {
+ cd "${srcdir}/aobook-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/aobook-${pkgver}"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
+
+md5sums=('48965417717ee70ad95b8b06b36e076b')