diff options
author | Aman Verma | 2020-12-09 05:19:33 -0500 |
---|---|---|
committer | Aman Verma | 2020-12-09 05:19:33 -0500 |
commit | 90c30329d9b8a7a1cd0e1e99f42409fcd83155a2 (patch) | |
tree | 64de6cbecc66805f3bce61b203e517c270da8c78 /PKGBUILD | |
parent | d79787ab69d40cad136a26a6e4a435bb1f3abc38 (diff) | |
download | aur-90c30329d9b8a7a1cd0e1e99f42409fcd83155a2.tar.gz |
Add basic checks.
Diffstat (limited to 'PKGBUILD')
-rw-r--r-- | PKGBUILD | 8 |
1 files changed, 8 insertions, 0 deletions
@@ -17,6 +17,14 @@ build() { pod2man --utf8 rename rename.1 } +check() { + mkdir -p "rename-$pkgver/tests" + cd "rename-$pkgver/tests" + touch foo.doc bar.doc + ../rename -s .doc .txt *.doc + stat foo.txt bar.txt >/dev/null +} + package() { cd "rename-$pkgver" # Change name to "prename" to not conflict with util-linux. |