summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorChocobo12023-04-06 03:37:06 +0800
committerChocobo12023-04-06 03:37:06 +0800
commitd73b281c3a570e5b43e2731765ef3d081197b3dc (patch)
treed0e32331fe2cd84f99b3ba4885b9bf87ac5f79b4 /PKGBUILD
parent767a2c09064f5e539a59a6ecfec93c0253222cd4 (diff)
downloadaur-d73b281c3a570e5b43e2731765ef3d081197b3dc.tar.gz
upgpkg: apache-git 2.4.57.rc1.candidate.r11191.g4859071fd0-1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c962eb9ed17d..9330a74ab3ba 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=apache-git
-pkgver=2.4.56.r11191.g4859071fd0
+pkgver=2.4.57.rc1.candidate.r11191.g4859071fd0
pkgrel=1
pkgdesc="Provides useful functions commonly found on BSD systems"
arch=('i686' 'x86_64')
@@ -50,10 +50,10 @@ prepare() {
pkgver() {
cd "httpd"
- _tag=$(git tag -l --sort -v:refname | grep -E '^[0-9\.]+$' | head -n1)
+ _tag=$(git tag -l --sort -creatordate | grep -E '^[0-9\.]+' | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/-/./g'
}
build() {