summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Claßen2018-12-01 17:03:34 +0100
committerPhilipp Claßen2018-12-01 17:03:34 +0100
commit69165976822f0431e3d607e000bae076931bc952 (patch)
treeac7703a90ea249f29f5d6a459cc399b62f10ae64 /PKGBUILD
parent2edfe3cdd653d132619705d4296c3f7e724f8e17 (diff)
downloadaur-69165976822f0431e3d607e000bae076931bc952.tar.gz
- update to 3.3.4
- remove obsolete workaround for startup issues
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 3 insertions, 10 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f2712a9cc0ad..f17699cbd0d5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=apache-gremlin-console
-pkgver=3.3.2
+pkgver=3.3.4
pkgrel=1
pkgdesc="Gremlin console from Apache TinkerPop "
arch=('any')
@@ -10,7 +10,7 @@ license=('Apache')
depends=('bash' 'java-environment')
makedepends=()
source=(https://www.apache.org/dist/tinkerpop/${pkgver}/apache-tinkerpop-gremlin-console-${pkgver}-bin.zip)
-sha256sums=('a049a2ec3a45a586fc3b68f6a212da56726fb932b8479ce7d7f4af1fc8234eb4')
+sha256sums=('c4605cd21f242649934e44b9f9599583f1994be04035fa358859d630d7dca1ba')
package() {
cd apache-tinkerpop-gremlin-console-${pkgver}
@@ -23,15 +23,8 @@ package() {
done
mkdir -p "${pkgdir}/usr/bin"
- printf "#!/bin/sh\ncd /usr/share/${pkgname}/bin\n./gremlin.sh \"\$@\"" >> "${pkgdir}/usr/bin/gremlin"
+ printf "#!/bin/sh\ncd /usr/share/${pkgname}/bin\n./gremlin.sh \"\$@\"" > "${pkgdir}/usr/bin/gremlin"
chmod 755 "${pkgdir}/usr/bin/gremlin"
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-
- # Workaround for the following startup exception:
- # Exception in thread "main" java.io.FileNotFoundException: /usr/share/apache-gremlin-console/bin/../ext/plugins.txt
- #
- # Possible fix: skip the cleanup if the file is not writable:
- # https://github.com/apache/tinkerpop/blob/master/gremlin-console/src/main/groovy/org/apache/tinkerpop/gremlin/console/Console.groovy#L137
- chmod a+w "${pkgdir}/usr/share/${pkgname}/ext/plugins.txt"
}