summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhilipp Claßen2016-07-26 01:04:39 +0200
committerPhilipp Claßen2016-07-26 01:04:39 +0200
commitf848b4db9642302bc08744219b8fad4c1454925d (patch)
treec2776496c0ecda97618b28564f794abe4b5cfc8d /PKGBUILD
parent3b1123e76913fcec872542f82fb6a9a3afec58b7 (diff)
downloadaur-f848b4db9642302bc08744219b8fad4c1454925d.tar.gz
- Fixed: TinkerPop is no longer in Incubation status (it graduated on 2016-05-23)
- Update from version 3.2.0 to version 3.2.1
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a631cf1946e4..16165adb1d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Philipp Claßen <philipp.classen@posteo.de>
pkgname=apache-gremlin-console
-pkgver=3.2.0
+pkgver=3.2.1
pkgrel=1
pkgdesc="Gremlin console from Apache TinkerPop "
arch=('any')
-url="https://tinkerpop.incubator.apache.org"
+url="https://tinkerpop.apache.org"
license=('Apache')
depends=('bash' 'java-environment')
makedepends=()
-source=(https://www.apache.org/dist/incubator/tinkerpop/${pkgver}-incubating/apache-gremlin-console-${pkgver}-incubating-bin.zip)
-md5sums=('c6e1ad041b09f96f5e3f3e68e8b3c6e8')
-sha256sums=('d3d58009557c900b641413eaf1adfc2a8b47d058b981a5d235924a5c9021af90')
+source=(https://www.apache.org/dist/tinkerpop/${pkgver}/apache-gremlin-console-${pkgver}-bin.zip)
+md5sums=('e1164c7d5e896ed35e9f83d7f1ebc9c2')
+sha256sums=('e028875e0a33141d6e3c093e5f7724f51d17a18db7ddf19ddd7658ca26e407ef')
package() {
- cd apache-gremlin-console-${pkgver}-incubating
+ cd ${pkgname}-${pkgver}
mkdir -p "${pkgdir}/usr/share/${pkgname}/bin"
cp bin/gremlin.sh "${pkgdir}/usr/share/${pkgname}/bin"
@@ -33,6 +33,6 @@ package() {
# Exception in thread "main" java.io.FileNotFoundException: /usr/share/apache-gremlin-console/bin/../ext/plugins.txt
#
# Possible fix: skip the cleanup if the file is not writable:
- # https://github.com/apache/incubator-tinkerpop/blob/master/gremlin-console/src/main/groovy/org/apache/tinkerpop/gremlin/console/Console.groovy#L137
+ # https://github.com/apache/tinkerpop/blob/master/gremlin-console/src/main/groovy/org/apache/tinkerpop/gremlin/console/Console.groovy#L137
chmod a+w "${pkgdir}/usr/share/${pkgname}/ext/plugins.txt"
}