summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorPhillip Smith2015-06-01 15:23:59 +1000
committerPhillip Smith2015-06-01 15:23:59 +1000
commit35d5566257674aad86bf1f3b47f25c23732d2446 (patch)
tree4ed6e77a1989988b79655e2afd56843d240940ce /PKGBUILD
downloadaur-35d5566257674aad86bf1f3b47f25c23732d2446.tar.gz
initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8919492a6bc8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Contributor: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=apache-mod_geoip2
+pkgver=1.2.8
+pkgrel=1
+pkgdesc="geoip interface module for apache."
+arch=('i686' 'x86_64')
+url="http://www.maxmind.com/app/mod_geoip"
+license=('LGPL')
+depends=('apache' 'geoip')
+makedepends=('apache' 'geoip')
+source=("http://geolite.maxmind.com/download/geoip/api/mod_geoip2/mod_geoip2_$pkgver.tar.gz")
+md5sums=('adab5ca32be41980155e07c8c8bcfc87')
+
+build() {
+ cd $srcdir/mod_geoip2_$pkgver
+ apxs -lGeoIP -L/usr/lib -I/usr/include -c mod_geoip.c
+}
+
+package() {
+ cd $srcdir/mod_geoip2_$pkgver
+ install -Dm0755 .libs/mod_geoip.so $pkgdir/usr/lib/httpd/modules/mod_geoip.so
+}
+
+# vim:set ts=2 sw=2 et: