summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorValHue2016-05-13 14:26:58 +0200
committerValHue2016-05-13 14:26:58 +0200
commit272d9b96d4393f0ddd5502472fe5bf8c2af036af (patch)
treeaee415d04abc07460465d6310742f71b1a281a00 /PKGBUILD
downloadaur-272d9b96d4393f0ddd5502472fe5bf8c2af036af.tar.gz
Initial import
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD42
1 files changed, 42 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0676f0236a3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: ValHue <vhuelamo at gmail dot com>
+# https://github.com/ValHue/AUR-PKGBUILDs
+
+pkgname="apertium-viewer"
+pkgver=2.5.2
+pkgrel=1
+pkgdesc="A tool to view and edit the output of the various stages of an apertium translation."
+url="http://wiki.apertium.org/wiki/Apertium-view"
+arch=('i686' 'x86_64')
+license=('GPL2')
+depends=('java-environment')
+conflicts=("${pkgname}")
+provides=("${pkgname}")
+source=("https://svn.code.sf.net/p/apertium/svn/builds/apertium-viewer/apertium-viewer.jar")
+sha256sums=('de5e7367ec2b890c1d3a97c75ba0819d25ff78b393154cc190e1324ca509e062')
+options=()
+
+_apertium_viewer_desktop="[Desktop Entry]
+Encoding=UTF-8
+Version=1.0
+Type=Application
+Exec=apertium-viewer
+Name=Apertium Viewer
+Icon=apertium.png"
+
+build() {
+ cd "${srcdir}"
+ echo -e "$_apertium_viewer_desktop" | tee apertium-viewer.desktop
+ echo "java -Xmx500m -jar /usr/share/apertium/apertium-viewer.jar" > apertium-viewer
+}
+
+package() {
+ cd "${srcdir}"
+ install -d ${pkgdir}/usr/bin
+ install -d ${pkgdir}/usr/share/{apertium,applications,pixmaps,}
+ install -m 644 apertium-viewer.jar "${pkgdir}/usr/share/apertium/"
+ install -m 644 *.desktop "${pkgdir}/usr/share/applications/"
+ install -m 644 apertiumview/resources/apertium.png "${pkgdir}/usr/share/pixmaps/"
+ install -m 755 apertium-viewer "${pkgdir}/usr/bin/"
+}
+
+# vim:set ts=4 sw=2 ft=sh et: \ No newline at end of file