summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorAdam Harvey2018-05-15 16:09:18 -0700
committerAdam Harvey2018-05-15 16:09:18 -0700
commitc590cd166f5abb1801d45d96ce27df6de73b0c5a (patch)
tree5277e62285ea94fa62f02be3476c622caa2ca0f8 /PKGBUILD
downloadaur-c590cd166f5abb1801d45d96ce27df6de73b0c5a.tar.gz
Initial commit.
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD44
1 files changed, 44 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cde6c2086735
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Adam Harvey <adam@adamharvey.name>
+pkgname=apfs-fuse-git
+pkgver=r45.7da8083
+pkgrel=1
+pkgdesc="FUSE driver for APFS (Apple File System)"
+arch=('i686' 'x86_64')
+url="https://github.com/sgan81/apfs-fuse"
+license=('GPL')
+groups=()
+depends=('fuse3')
+makedepends=('git' 'fuse3' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('apfs-fuse::git+https://github.com/sgan81/apfs-fuse')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ git submodule update --init
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p build
+ cd build
+ cmake ..
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p "$pkgdir/usr/bin"
+ install -Dm755 build/bin/{apfs-dump,apfs-dump-quick,apfs-fuse,lzfse} "$pkgdir/usr/bin"
+}