summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorfumseck2017-11-14 18:56:22 +0100
committerfumseck2017-11-14 18:56:22 +0100
commitecbe143b8d814c0c9a8b4055ff749fb7d34bab19 (patch)
treeb9db20b7e6db24d6e66f75bc59b40dac3350c0ab /PKGBUILD
parent64dee1d3319f63c0a71913387919ef428bbba415 (diff)
downloadaur-ecbe143b8d814c0c9a8b4055ff749fb7d34bab19.tar.gz
use composer to donhrodite
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 10773a74a419..a64c29566650 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,14 +9,11 @@ arch=('any')
url="https://github.com/fumseck/aphrodite"
license=('GPL3')
depends=('php>=7' 'php-apache' 'apache' 'php-pgsql' 'postgresql' 'sqlite' 'mariadb' 'make' 'git' 'composer' 'php-sqlite' )
-source=(http://git.fumseck.eu/cgit/aphrodite/snapshot/$pkgname-$pkgver.tar.gz)
-md5sums=('10a9aa2467b2d112a4a83df58f6eca24')
build()
{
- cd "$pkgname-$pkgver"
-
- make
+ composer create-project imperium/aphrodite $pkgname
+
}
package()
@@ -26,5 +23,5 @@ package()
if [ -d "/srv/http/$pkgname" ];then
sudo rm -rf "/srv/http/$pkgname"
fi
- sudo mv $pkgname-$pkgver "/srv/http/$pkgname"
+ sudo mv $pkgname "/srv/http"
}