summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMubashshir2020-12-23 12:54:17 +0600
committerMubashshir2020-12-23 12:54:17 +0600
commit14a6be1b6c13943b61fa7133104fe845bb755a89 (patch)
tree92e11256897dfdba6b2fc74a8a468fd979fe6972 /PKGBUILD
parent4f18ee9cb7cc769a42ec88fde6dc25fc41d4bd65 (diff)
downloadaur-14a6be1b6c13943b61fa7133104fe845bb755a89.tar.gz
update
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 16 insertions, 5 deletions
diff --git a/PKGBUILD b/PKGBUILD
index a57c627e1de7..1785bd96d1b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,10 @@
-# Maintainer: William Luc Ritchie <luc dot ritchie at gmail dot com>
+# Maintainer: Mubashshir <ahmubashshir@gmail.com>
+# Contributor: William Luc Ritchie <luc dot ritchie at gmail dot com>
# Contributor: Borja Ruiz <borja [at] libcrack [dot] so>
_pkgname=apkstudio
pkgname=$_pkgname-git
-pkgver=r211.5b6f115
+pkgver=r299.71ca9b5
pkgrel=1
epoch=1
pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
@@ -12,17 +13,27 @@ url='http://www.vaibhavpandey.com/apkstudio/'
license=('GPL2')
depends=('qt5-base' 'android-tools')
makedepends=('git' 'qt5-tools' 'unzip')
-source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git')
-sha256sums=('SKIP')
+source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git'
+ 'git+https://github.com/Dax89/QHexView.git'
+ 'git+https://github.com/Jorgen-VikingGod/Qt-Frameless-Window-DarkStyle')
+sha256sums=('SKIP' 'SKIP' 'SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/$_pkgname"
+ git submodule init
+ for n in QHexView Qt-Frameless-Window-DarkStyle;do
+ git config submodule."$n".url $srcdir/$n
+ done
+ git submodule update
+}
+
build() {
cd "$srcdir/$_pkgname"
- lrelease-qt5 res/lang/en.ts
qmake-qt5 -r apkstudio.pro CONFIG+=release
make
}