summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuc Ritchie2018-04-18 09:46:39 -0400
committerLuc Ritchie2018-04-18 09:48:12 -0400
commit4f18ee9cb7cc769a42ec88fde6dc25fc41d4bd65 (patch)
tree9b09b658a3bd12e3658051f738d90c6af457e963 /PKGBUILD
parent0d1b1807225106067d74dfbd8804b8cf8bdd3f7f (diff)
downloadaur-4f18ee9cb7cc769a42ec88fde6dc25fc41d4bd65.tar.gz
Stop being opinionated about upstream post-install setup
It now requires tools that aren't available as dependencies anyway
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD21
1 files changed, 4 insertions, 17 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 6ad3b7abbf82..a57c627e1de7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,34 +3,23 @@
_pkgname=apkstudio
pkgname=$_pkgname-git
-pkgver=r100.9e114ca
+pkgver=r211.5b6f115
pkgrel=1
epoch=1
pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
arch=('i686' 'x86_64')
url='http://www.vaibhavpandey.com/apkstudio/'
license=('GPL2')
-depends=('qt5-base' 'android-tools' 'android-apktool')
+depends=('qt5-base' 'android-tools')
makedepends=('git' 'qt5-tools' 'unzip')
-source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git'
- 'APKTOOL_VERSION'
- 'apkstudio-setup.sh'
- 'change-vendor-zip-warning.patch')
-sha256sums=('SKIP'
- 'ff6ea79b60edfc59c6556ba1f349aae9da3cbb99d5d35239521ebb8f3a201a8c'
- 'f750ecf7d4ddf14922aa52e98ec37f6277692bd88f934f4a3a41b0e888017a1d'
- 'addf387dfb760341e694c9fe50900b7e39acd71f4ff7e3b793ae9347c2b9c0ab')
+source=('git+https://github.com/vaibhavpandeyvpz/apkstudio.git')
+sha256sums=('SKIP')
pkgver() {
cd "$srcdir/$_pkgname"
printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
-prepare() {
- cd "$srcdir/$_pkgname"
- patch -p0 -i ../change-vendor-zip-warning.patch
-}
-
build() {
cd "$srcdir/$_pkgname"
lrelease-qt5 res/lang/en.ts
@@ -41,6 +30,4 @@ build() {
package() {
cd "$srcdir"
install -Dm755 "$_pkgname/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
- install -Dm744 'APKTOOL_VERSION' "$pkgdir/usr/share/$pkgname/APKTOOL_VERSION"
- install -Dm755 'apkstudio-setup.sh' "$pkgdir/usr/bin/apkstudio-setup.sh"
}