summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorLuc Ritchie2015-07-10 02:11:14 -0400
committerLuc Ritchie2015-07-10 05:20:40 -0400
commitaedb7fde08f9ab58ae74359fb598846468cc5bf0 (patch)
tree80288abf5330c4641d05f8ccd806a6ab46f7d389 /PKGBUILD
downloadaur-aedb7fde08f9ab58ae74359fb598846468cc5bf0.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c609e1f371d7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: William Luc Ritchie <luc dot ritchie at gmail dot com>
+# Contributor: Borja Ruiz <borja [at] libcrack [dot] so>
+
+_pkgname=apkstudio
+pkgname=$_pkgname-git
+pkgver=r2.b1e443a
+pkgrel=1
+pkgdesc='An IDE for decompiling/editing & then recompiling of android application binaries.'
+arch=('i686' 'x86_64')
+url='http://apkstudio.codeplex.com/'
+license=('GPL2')
+depends=('qt5-base')
+makedepends=('git')
+source=('git+https://git01.codeplex.com/apkstudio.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ mkdir build
+ cd build
+ qmake-qt5 -r ../apkstudio.pro
+ make
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ install -Dm755 "build/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}