summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2021-03-02 01:03:59 -0700
committerMark Wagie2021-03-02 01:03:59 -0700
commite4143ecf019ad610ed916934a4c7c231dbf10551 (patch)
tree155436dca0eb9d2dea84ca238eb170a1abc2fa58 /PKGBUILD
parent3f28977929fbf7303d664decdca9bf3901268784 (diff)
downloadaur-e4143ecf019ad610ed916934a4c7c231dbf10551.tar.gz
2.3
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD11
1 files changed, 5 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f4a785cc96d6..aa7bf637d8aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,18 @@
# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
pkgname=apostrophe
-pkgver=2.2.0.3
-pkgrel=3
+pkgver=2.3
+pkgrel=1
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
url="https://somas.pages.gitlab.gnome.org/apostrophe"
license=('GPL3')
depends=('webkit2gtk' 'gspell' 'python-pypandoc' 'python-regex' 'python-levenshtein'
- 'python-pyenchant' 'python-gobject' 'python-cairo' 'otf-fira-mono')
+ 'python-pyenchant' 'python-gobject' 'python-cairo' 'otf-fira-mono' 'libhandy')
makedepends=('meson' 'gobject-introspection')
-checkdepends=('appstream')
optdepends=('texlive-latexextra: for the pdftex module'
'mathjax: for formula preview')
source=("https://gitlab.gnome.org/somas/apostrophe/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
-sha256sums=('79b7aa4913eceaf3a81baa23fe1071ae462b17f6b0f77d8e69f3d554474b4cab')
+sha256sums=('944ee2d83c05afac148e1b819c213274f544c23e5338088271e967a6e83a09d2')
build() {
arch-meson "$pkgname-v$pkgver" build
@@ -21,7 +20,7 @@ build() {
}
check() {
- meson test -C build
+ meson test -C build --print-errorlogs
}
package() {