summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMark Wagie2020-06-26 11:48:09 -0600
committerMark Wagie2020-06-26 11:48:09 -0600
commitae17e030cd8a1ecfa2cb33c961dc761a6a979c4b (patch)
tree820754e151891aa92bb79f99ce914d0ec9ca7c32 /PKGBUILD
parentcb39f1f1efa0547a3ab68672de777d615098d350 (diff)
downloadaur-ae17e030cd8a1ecfa2cb33c961dc761a6a979c4b.tar.gz
adjust depends, add test
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e3ed0b3e5112..ae432d4896f7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Co-Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
# Contributor: Philip Goto <philip.goto@gmail.com>
pkgname=apostrophe-git
-pkgver=2.2.0.3.r0.gdaf77a6
+pkgver=2.2.0.3.r29.gd5a9fdc
pkgrel=1
pkgdesc="A distraction free Markdown editor for GNU/Linux made with GTK+"
arch=('any')
@@ -10,7 +10,8 @@ url="https://gitlab.gnome.org/somas/apostrophe"
license=('GPL3')
depends=('webkit2gtk' 'gspell' 'python-pypandoc' 'python-regex' 'python-levenshtein'
'python-pyenchant' 'python-gobject' 'python-cairo' 'gobject-introspection')
-makedepends=('git' 'meson' 'appstream-glib')
+makedepends=('git' 'meson')
+checkdepends=('appstream')
optdepends=('texlive-latexextra: for the pdftex module'
'mathjax: for formula preview'
'otf-fira-mono: Recommended font (OTF)'
@@ -27,9 +28,13 @@ pkgver() {
build() {
arch-meson "${pkgname%-git}" build
- ninja -C build
+ meson compile -C build
+}
+
+check() {
+ meson test -C build
}
package() {
- DESTDIR="$pkgdir" ninja -C build install
+ DESTDIR="$pkgdir" meson install -C build
}