summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authornl67202018-10-03 09:38:02 +0300
committernl67202018-10-03 09:38:02 +0300
commit5e742dcdb523571e652064d519d114876909af22 (patch)
tree19b65fdba1bb762566346d951333dee4f856d031 /PKGBUILD
parent21fd3a7d9eda6a6e73d1010ccc23c462454da571 (diff)
downloadaur-5e742dcdb523571e652064d519d114876909af22.tar.gz
apparmor-git 2.13.r237.g63cb46d2
Build and install binutils. Those are: "aa-enabled" and "aa-exec". Add check() and run tests. The tests for "utils" and "profiles" are not run because they fail. "parser" tests take a very long time!
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD19
1 files changed, 16 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c3512db74517..e96551d323e8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: David Runge <dave@sleepmap.de>
pkgname=apparmor-git
-pkgver=2.13.r234.g395aed72
+pkgver=2.13.r237.g63cb46d2
pkgrel=1
pkgdesc='Mandatory Access Control (MAC) using Linux Security Module (LSM)'
arch=('x86_64')
@@ -10,6 +10,8 @@ url='https://gitlab.com/apparmor/apparmor'
license=('GPL')
depends=('audit' 'pam' 'python')
makedepends=('git' 'swig' 'chrpath' 'ruby')
+checkdepends=('dejagnu' 'perl-locale-gettext')
+ # 'python-pyflakes'
optdepends=('perl: perl bindings'
'ruby: ruby bindings')
conflicts=("${pkgname%-git}")
@@ -45,7 +47,7 @@ prepare() {
# fix default vim syntax file installation path
sed -e 's/share\/apparmor/share\/vim\/vimfiles\/syntax/' -i utils/vim/Makefile
cd "${srcdir}/${pkgname%-git}/libraries/libapparmor"
- autoreconf -vfi
+ ./autogen.sh
}
build() {
@@ -59,12 +61,13 @@ build() {
--prefix=/usr \
--sbindir=/usr/bin \
--sysconfdir=/etc \
- --with-pic=yes \
+ --with-pic \
--with-perl \
--with-python \
--with-ruby
make
cd "${srcdir}/${pkgname%-git}"
+ make -C binutils
make -C parser
make -C profiles
make -C utils
@@ -72,10 +75,20 @@ build() {
make -C utils/vim
}
+check() {
+ cd "${srcdir}/${pkgname%-git}"
+ make -C libraries/libapparmor check
+ make -C binutils check
+ make -C parser check
+ #make -C utils check
+ #make -C profiles check
+}
+
package() {
cd "${srcdir}/${pkgname%-git}"
make -C libraries/libapparmor DESTDIR="${pkgdir}" install
make -C changehat/pam_apparmor DESTDIR="${pkgdir}/usr" install
+ make -C binutils DESTDIR="${pkgdir}" install
make -C parser DESTDIR="${pkgdir}" USR_SBINDIR="${pkgdir}/usr/bin" install
make -C parser DESTDIR="${pkgdir}" USR_SBINDIR="${pkgdir}/usr/bin" install-systemd
make -C profiles DESTDIR="${pkgdir}" install