summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorJoão Miguel2017-07-19 15:35:26 +0100
committerJoão Miguel2017-07-19 16:50:53 +0100
commit4068c4cc74aa33090d804a2d57e05b598fa1f886 (patch)
tree961f1cbe396e6c5fda51a55e19c55979744086e3 /PKGBUILD
parente4fed9916cd8ede9356ea951927b4ed65f5da840 (diff)
downloadaur-4068c4cc74aa33090d804a2d57e05b598fa1f886.tar.gz
Changed /usr/libexec to /usr/lib/apparmor
(since apparmor-parser no longer provides it as a symlink)
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD12
1 files changed, 8 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e8e84519b382..33d35ddff6af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: João Miguel <jmcf125 at openmailbox dot org>
pkgname=apparmor-openrc
-pkgver=20160816
+pkgver=20170719
pkgrel=1
pkgdesc="Apparmor init script for OpenRC (from systemd-free.org - not apg's way)"
arch=('any')
@@ -19,10 +19,14 @@ pkgver() {
_inst_initd(){
install -Dm755 ${srcdir}/$1.initd ${pkgdir}/etc/init.d/$1
+ # vv--- should work without this, but actually does not (at boot)
sed -e 's|#!/sbin/runscript|#!/usr/bin/openrc-run|' \
- -e 's|/var/run|/run|g' \
- -i "${pkgdir}/etc/init.d/$1"
- # ^^--- should work without this, but actually does not (at boot)
+ -e 's|/var/run|/run|g' \
+ -e 's|libexec|lib/apparmor|' \
+ -i "${pkgdir}/etc/init.d/$1"
+ # /usr/libexec/rc.apparmor.functions is needed: /usr/libexec used to be a
+ # link created by some apparmor package, but not anymore (see:
+ # https://wiki.archlinux.org/index.php/Arch_packaging_standards#Package_etiquette)
}
package() {