summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMazhar Hussain2023-12-26 09:57:32 +0500
committerMazhar Hussain2023-12-26 09:57:32 +0500
commit436d61616930ff03df9d60fdf0bb975549ca2b89 (patch)
tree20d4d6fb62697ad895f422829997930720b4d5c6 /PKGBUILD
downloadaur-436d61616930ff03df9d60fdf0bb975549ca2b89.tar.gz
Initial commit
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..acf5aec2b06c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Mazhar Hussain <realmazharhussain@gmail.com>
+pkgname=appimaged-bin
+pkgdesc="Deprecated: A daemon that monitors the system and integrates AppImages"
+url="https://github.com/AppImageCommunity/appimaged"
+pkgver=r199
+pkgrel=1
+arch=(x86_64)
+license=(MIT)
+depends=(gdk-pixbuf2)
+source=("appimaged.AppImage"::"https://github.com/AppImageCommunity/appimaged/releases/download/continuous/appimaged-x86_64.AppImage")
+sha256sums=(0cb439698ccd542c622c5aec5496efb0fe6a56575b16be9e77bd5467b97b4555)
+
+prepare() {
+ chmod +x appimaged.AppImage
+}
+
+package() {
+ for pattern in usr/{lib/systemd,bin,share/{applications,icons,metainfo}}; do
+ ./appimaged.AppImage --appimage-extract "${pattern}"
+ done
+
+ mv -fT squashfs-root "${pkgdir}"
+}