summarylogtreecommitdiffstats
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMazhar Hussain2023-12-26 10:20:37 +0500
committerMazhar Hussain2023-12-26 10:20:37 +0500
commit651997c825fb90a41561e9e571639fa235435888 (patch)
tree57e989b6d39826caeffae5de738469208c859edb /PKGBUILD
parent436d61616930ff03df9d60fdf0bb975549ca2b89 (diff)
downloadaur-651997c825fb90a41561e9e571639fa235435888.tar.gz
Add a LICENSE file & Fix file-permissions of directories
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD20
1 files changed, 17 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index acf5aec2b06c..8d44a06893d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,18 @@ pkgname=appimaged-bin
pkgdesc="Deprecated: A daemon that monitors the system and integrates AppImages"
url="https://github.com/AppImageCommunity/appimaged"
pkgver=r199
-pkgrel=1
+pkgrel=2
arch=(x86_64)
license=(MIT)
depends=(gdk-pixbuf2)
-source=("appimaged.AppImage"::"https://github.com/AppImageCommunity/appimaged/releases/download/continuous/appimaged-x86_64.AppImage")
-sha256sums=(0cb439698ccd542c622c5aec5496efb0fe6a56575b16be9e77bd5467b97b4555)
+source=(
+ "appimaged.AppImage"::"https://github.com/AppImageCommunity/appimaged/releases/download/continuous/appimaged-x86_64.AppImage"
+ "LICENSE"::"https://github.com/AppImageCommunity/appimaged/raw/continuous/LICENSE"
+)
+sha256sums=(
+ 0cb439698ccd542c622c5aec5496efb0fe6a56575b16be9e77bd5467b97b4555
+ b54da09f0d48f1c42a1b27035711ed41494551ed8a20b991746e669e6f944a94
+)
prepare() {
chmod +x appimaged.AppImage
@@ -19,5 +25,13 @@ package() {
./appimaged.AppImage --appimage-extract "${pattern}"
done
+ for directory in $(find squashfs-root -type d); do
+ chmod 755 "${directory}"
+ rmdir --parents --ignore-fail-on-non-empty "${directory}"
+ done
+
mv -fT squashfs-root "${pkgdir}"
+
+ mkdir --parents "${pkgdir}/usr/share/licenses/${pkgname}"
+ cp LICENSE --target-directory "${pkgdir}/usr/share/licenses/${pkgname}"
}